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LAYERS

As you include more objects into your artwork and it begins to
become more complex, you may find that you need a way to
effectively organise your artwork so you can work with specific
elements at a time.

Fortunately you can use Layers to manage your artwork and make
it easier to work with. The elements on each lllustrator page
appear in layers. A document may have one layer, meaning that
every element or object appears at the same level, or a document
may have several layers, where some objects appear on one layer
and some on another. Objects in the higher or top layer sit over
those on the lower layers. The best way to think of layers is to see
them as transparent sheets, each with their own objects that are
laid over the top of each other to form a page.

In this session you will:

<

gain an understanding of layers and sublayers
gain an understanding of the Layers panel
learn how to use the Layers panel to select objects
learn how to create layers

learn how to name layers and assign colours
learn how to group layers

learn how to move objects to different layers
learn how to rearrange layers and sublayers
learn how to hide and display layers

learn how to lock and unlock layers

learn how to delete layers.
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UNDERSTANDING LAYERS AND SUBLAYERS

You can arrange objects in lllustrator by using Alternatively, you can organise objects into layers
commands located in the Arrange menu. For using the Layers panel. Using layers saves time
instance you can use the commands to position when editing objects, especially in complex
objects in front of and behind each other. artwork.

Understanding Layers

Layers can be thought of as transparent sheets that are placed over the top of each other on a page. Only the
objects on the layers are visible — the rest of the sheet is transparent. For example, if you add elements to a
document, such as an image or text, it is placed in a new layer as ifon a transparent sheet on top of the
original image. By default each new lllustrator document has a single layer called Layer 1. As you add
elements to an artwork sublayers are created by default and you also have the option of creating additional
layers or sublayers.

You can choose to hide or display layers so that only one or two may be visible at a time. This enables you to
concentrate on the objects on the current layer(s) and the objects on the hidden layers are effectively
protected from inadvertent modification or deletion. For instance, if you place all of the text in a document on
one layer and the graphics on another, you can hide all of the graphics and print only the text. This is ideal if
you need to proof read the text. Alternatively, you can hide the text layer and display the graphics layer while
you import pictures. You can also create additional layers and sublayers to better control, manage and
organise your artwork. By using the options in the Layers panel, you can isolate objects for editing by hiding
or locking surrounding objects. You can also rearrange objects in the layer/sublayer hierarchy. You may find
that as you add more elements to your art, you will need to create new layers and move objects/sublayers
between layers.

Understanding Sub Layers

Sublayers are layers within a layer. You can view sublayers in the Layers panel by clicking on the expand
arrow to the left of the layer name. Sublayers will appear listed below the layer name they belong to.
Sublayers are created by default when you place elements on an artboard. For instance, if you draw a
rectangle on Layer 1, it will be placed on a sublayer within Layer 1 named Rectangle. Sublayers are useful in
that they organise elements of a document within a layer.

Grouping Layers

You can create a layer group by selecting multiple elements on a layer and selecting Object > Group. This
will create what appears to be a sublayer within the selected layer however it does not work in quite the same
way as a sublayer. If you group objects together, their individual sublayers will be merged into a single
sublayer called Group. If you ungroup the objects they will revert back to their original sublayers.

The Uses of Layers

Layer
clipping
mask

PDF layers Export PDF files with layers preserved

Make the top object in a layer a mask for all items within that layer

Photoshop preserve layers in a file to be exported to Photoshop to make it easier to work with inside

export Photoshop

Animation  When working with animation, layers serve as frames.

CSSs Can be exported to CSS layers when creating web layouts
SVG Basic building blocks when creating files to be saved as SVG

Variables XML based variables feature relies on layers

Because every item is on a separate sublayer (unless grouped), you are able to stack or
position objects on top of or behind other objects by adjusting the sublayer’s position in the
stack. You can send objects to the back of other objects (lowest in the sublayer hierarchy), or
bring them to the front (highest in the sublayer hierarchy). You can also bring an object forward
one sublayer (move it up one level) or send it backward one sublayer (to send it behind the
next sublayer in the hierarchy). Objects on the same layer can be arranged using the
commands in the Object > Arrange menu.

Arranging
Objects
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UNDERSTANDING THE LAYERS PANEL

The order in which layers appear in the objects as it is the top layer. You can use the
Layers panel indicates the order of objects in Layers panel to create and delete layers, hide
the document. In the example below, objects all or parts of a layer and move objects between
in the Logo layer are in front of all other layers.
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The Panel
Options menu

The Visibility column allows you to turn the visibility of a layer or multiple layers on or off. If the
visibility of a layer is turned off, any elements located on that layer are no longer visible and cannot
be edited.

The Edit column allows you to lock and unlock layers. If a layer is locked, elements on that layer
are visible but they cannot be modified in any way. To lock a layer click on the lock box so a lock
icon appears. To unlock a layer click on the lock icon so it disappears.

The colour that is assigned to the layer appears to the left of the layer name. The arrow to the left
of the layer name allows you to expand or collapse the sublayers within a layer.

00 0 ©

The Target column allows you to select all elements on a layer. Click on the target icon for the
required layer. To deselect the elements click on the Target icon again. The area to the right of the
Target icon is known as the Selection column as it allows you to see which objects belong to
which layers. If you select an object in your artwork a small icon will appear in the Selection
column of the layer the object belongs to.

If you wish to know the exact location of a selected object, click on Locate Object. This expands
the relevant layer in the Layers panel so that you can see all of its sublayers. The sublayers that
contain elements of the selected object appear with the colour icon in the Target column.

A clipping mask works by clipping the artwork to the shape of the mask so that only elements of
the artwork within the mask are visible. Click on Make/Release Clipping Mask to either make a
clipping mask if there is not one selected, or release a selected clipping mask.

Click on Create New Sublayer to create a new sublayer in the selected layer. Click on Create
New Layer to create a new layer.

Click on Delete Selection to delete the selected layer(s) and/or sublayer(s).

©0 0 0
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WORKING WITH THE LAYERS PANEL

The Layers panel is included in the Essentials
workspace by default and contains a range of
features to help you work with individual objects
and groups of objects. You can access the

Layers panel using a number of different methods.
Simply select Layers from the panel dock
(depending on the selected workspace), select
Window > Layers, or press [7].

Try This Yourself:

Before starting this exercise you
MUST open the file IL1409
Layers_1.ai...

Open
File

Click on Layers in the panel dock to
display the Layers panel

All objects are contained within two
layers called Background and Layer
T

e Click on the Target icon for Layer 1,
as shown to select all objects on this
layer

A blue square next to the Target icon
indicates that all sublayers within
Layer 1 are selected. Notice that all
artboard objects are enclosed in a
blue bounding box...

o Click outside of the bounding box to
deselect the objects

Let's expand Layer 1 to see all
sublayers within this layer ...

o In the Layers panel, click on the
expand arrow to the left of Layer 1 to
display it's sublayers

Layer 1 is expanded to show a list of
sublayers, each containing objects
(groups and paths)...

o Click on the title bar of the Layers
panel, drag the panel into the
workspace so it appears floating ,
then point to the bottom right corner
of the panel to display a double-
headed arrow

o Click and drag down to expand the
panel to display all of the sublayers
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For Your Reference...
To display the Layers panel.
e Click on Layers in the panel dock, or
Select Window > Layers
To select layers/sublayers in the Layers panel.

« Click on the target icon to the right of the
layer or sublayer name

Handy to Know...

e When you select a sublayer in the Layers
panel, a square appears beside the name of
the sublayer and a smaller square also
appears beside the name of the (parent)
layer. This indicates that one or more objects
within the layer are selected (i.e. on the
sublayer), but not the (parent) layer itself.
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CREATING LAYERS AND SUBLAYERS

Layers are a useful way of keeping your objects
organised and making it easier to work with your
document. Although each new document in
lllustrator only has one layer, you can create and

name as many new layers and sublayers as you
need for each artwork. You might like to organise
your objects by their type, theme, or when they
were created.

Try This Yourself:

Continue using the
previous file with this
exercise, or open the file
IL1409 Layers_2.ai...

Same
File

In the Layers panel, click
on Create New Layer

The new layer is called
Layer 3. Let’s create
another layer using a
different method...

Click on the panel Options
menu to display a menu of
options

Select New Layer to create
a new layer and display the
Layer Options dialog box

Let’s create a sublayer...

Click on [OK] to create the
new layer with the default
settings applied

Ensure Layer 3 is selected
in the Layers panel

Click on Create new
sublayer at the bottom of
the Layers panel
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For Your Reference...
To create layers and sublayers:
* Inthe Layers panel, click on Create New
Layer, or
1. Select the required sublayers in the Layers
panel

2. Click on the panel options menu and select
Collect in New Layer

Handy to Know...

e You can create new layers by duplicating
existing ones. Select the required layer in the
Layers panel, click on the Panel options
menu, then select Duplicate Layer.
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NAMING LAYERS AND ASSIGNING COLOURS

By default, layers are known as Layer 1, Layer 2 layer names and colours to suit your particular
and so on. They are also assigned a specific project, so that specific objects are easier to locate
colour — light blue for Layer 1, red for Layer 2, and display.

green for Layer 3 and so on. You can change the

Try This Yourself:

Continue using the previous
file with this exercise, or open
the file IL1409 Layers_3.ai...

Same
File

Double-click on the Layer 3
label to select the text

Type Buttons, then pressienter]
to rename the layer

Repeat step 3 to rename
Layer 4 as Logo and Layer 1
as Headings

The colour assigned to both
the Logo and Headings layers
is blue. As this might be
confusing, let’s change one. ..

Double-click to the right of the
Logo layer label (not on the : emplate * Lock
label text) to display the Layer : ¥ print

Options dialog box g prcvion | Dl Enages hor XTI

Click on the drop arrow for
Colour, select Yellow, then
click on [OK]

Notice the colour to the left of
the Logo layer is now yellow

oK

For Your Reference... Handy to Know...
To change a layer colour or name: « You can change the number of layers that
1. Double-click on the layer name in the Layers are visible in the Layers panel by selecting
panel Small Panel Rows from the Layers panel
2. Change the Name and/or Colour menu button. This option reduces the vertical
s space each layer name occupies in the
3. Click on [OK] panel.
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GROUPING LAYERS

lllustrator allows you to group layers by ensure that layers are grouped in a way that works
collecting layers and creating one new layer. This to your advantage — whether you want to group

is useful if you have a large quantity of layers and them based on category, position within the artwork
sublayers in the Layers panel and need to etc.

Try This Yourself:

Continue using the
previous file with this
exercise, or open the file
IL1409 Layers_4.ai...

Same
File

On the artboard and
canvas, select the three
photos and the large
black rectangle

If necessary resize the
Layers panel so you can
clearly view all of the
layers and sublayers by
clicking and dragging on
the border of the panel

In the Layers panel, hold
down [ct1] and click on the
four sublayers displaying
the large blue squares

Click on the panel options
menu to display a menu
of options

Select Collect in New
Layer to move these four
sublayers into a single
sublayer (Layer 6)

Rename the layer
Graphics

© © 606 ©o

For Your Reference... Handy to Know...
To group layers: * You can merge layers using the Merge
1. Select the required |ayer5 Layers Option on the panel Optl'ons menu.

Merging layers takes multiple layers and
: makes them into one single layer. This is
3. Select Collect in New Layer useful if you have too many layers and the
artwork is becoming difficult to organise.

2. Click on the panel Options menu
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REASSIGNING OBJECTS TO DIFFERENT LAYERS

No matter how carefully you plan your artwork, it
is very likely you will need to move objects from
one layer or sublayer to another at some point.
For example, you might receive a document with

a single layer, and prefer the objects to be
arranged on several layers as you work on it. In this
case you would simply create new layers and move
the objects as required.

Try This Yourself:

Continue using the previous file
with this exercise, or open the file
IL1409 Layers_5.ai...

o On the artboard, click on the
Photography button to select it

A blue bounding box surrounds
the object and, in the Layers
panel, the sublayer that contains
the object displays a large blue
square if you are continuing from
the previous exercise, or pink if

Same
File

ey CHlIegE T
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you are using the Layers_3 file...

o In the Layers panel, point to the
large blue (or pink) square for the
active Group sublayer, then click
and drag it onto the Buttons
layer until the square appears
green

o Release the mouse button to
complete the move, then if
necessary click on the arrow for
Buttons to expand the layer

The Group sublayer has been
moved into the Buttons layer and
the Photography button now has
a green bounding box...

Repeat steps 1 to 3 to move the
Watercolour and Drawing
buttons into the Buttons layer

Click on the logo at the top of the
artboard to select it, then repeat
steps 2 and 3 to move it into the
(yellow) Logo layer

The bounding box will change to

o

Ay Conege T
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yellow

For Your Reference...
To move objects to different layers:
1. Select the object

2. Inthe Layers panel, click and drag the
coloured square to the new layer/sublayer

3. Release the mouse button

Handy to Know...

¢ You don't have to select the object on the
artboard before moving it to another layer or
sublayer — sometimes the tiny thumbnail in
the Layers panel is clear enough to make
out which is the target sublayer. You can
then click on the target icon for the layer to
reveal the square.
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REARRANGING LAYERS AND SUBLAYERS

Arranging (or stacking) layers and sublayers newest at the top. Rearranging layers and
enables you to adjust the hierarchy of objects in sublayers allows you to specify where objects

an artwork. By default, objects will be stacked in appear in the hierarchy and therefore how visible
the order in which they were created, with the they are.

Try This Yourself:

Continue using the previous file with
this exercise, or open the file IL1409
Layers_6.ai...

Same
File

o On the canvas, select the black
rectangle, then position it over the
three photos, as shown

In the Layers panel, you can see this
sublayer (Path) sits above the photos
and therefore obscures them...

Select Object > Arrange > Send to
Back

The sublayer is repositioned at the
bottom of the Graphics layer and
now appears behind the other
sublayer objects. Let's make the
Graphics sublayer into a layer...

G

Collapse all layers except Headings,
then click and drag the Graphics
sublayer up until a thick line appears
just above the Headings layer

Release the mouse button to
complete the move

Select the Apply Today text on the
pasteboard and position as shown

Select Object > Arrange > Bring to
Front

This does not work — although the
Apply Today sublayer moved to the
top of the Headings hierarchy, it is
still not above the Graphics layer...

©00 O

Repeat steps 3 and 4 to move the
Headings layer above the Graphics
layer

For Your Reference... Handy to Know...

To rearrange layers and sublayers: e The Object > Arrange menu options only

« Select the object, then select Object > move sublayers within a layer — they don’t
Arrange > option, or alter the hierarchy of layers. Remember each

o Collapse the layers in the Layers panel, then object is on its own sublayer in a hierarchy

click and drag the layer or sublayer to the determined by order of creation by default.
new position The most recently created object will be on

top, obscuring all items directly beneath it.
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HIDING AND DISPLAYING LAYERS

When you create artwork in lllustrator, you stack others and therefore obscure parts of the objects
the layers and sublayers so that the objects on directly underneath. In order to edit objects in lower
the layers are arranged to produce the final layers, it is easier to temporarily hide the layers on
result. Some objects are positioned on top of top rather than move the objects out of the way.

Try This Yourself:

Same
File

Continue using the previous
file with this exercise, or open
the file IL1409 Layers_7.ai...

Ensure that no objects are
selected, then, in the Layers
panel, click on the left
(Visibility) column for the
Background layer so that an
eye icon appears

The Background layer was
hidden and is now displayed
on the artwork. As this layer
is at the top of the hierarchy,
it obscures everything else
(all other layers and
sublayers are beneath it)...

With all layers collapsed in
the Layers panel, click and
drag the Background layer
to the bottom of the
hierarchy, until a thick line
appears below the Graphics
layer

Release the mouse button to
complete the move

Now the background is
positioned behind all other
layers and sublayers...

Expand the Headings layer,
then click on the Visibility

column for Apply Today! so
that the eye icon disappears

The sublayer is hidden and
the text can no longer be
seen on the artwork

! Lg l.‘l Graphics

For Your Reference... Handy to Know...
To hide and display layers and sublayers: « Hidden layers cannot be selected using the
e Click on the Visibility column for the layer or target icon in the Layers panel.
sublayer « Hiding layers can also be useful for creating
different versions in a single artwork; for
example, the same sales brochure for
diffierent franchises. You can display layers
relevant to each version.
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LOCKING AND UNLOCKING LAYERS

To avoid accidentally moving, deleting or editing
an object or group of objects, you can lock the
layer or sublayer they are on. Not only is it not
possible to change objects on a locked layer, you

cannot even select a layer or sublayer that is
locked. Like hiding layers, this is useful when you
want to work with certain objects without
inadvertently changing others.

Try This Yourself:

Same

File

Continue using the previous file
with this exercise, or open the
file IL1409 Layers_8.ai...

On the artboard, click on the
green background object

The background consists of a
gradient-filled square the same
size as the artboard. Notice that
a bounding box is not displayed
around this object — the
Background layer is locked and
cannot be selected...

In the Layers panel, click on the
lock icon for the Background
layer to remove the Lock icon

The layer is now unlocked...

Repeat step 1 to select the
background object

This time a bounding box
appears around the square on
the Background layer. Let's
remove the stroke...

In the Tools panel, click on the
Stroke box, click on None, then
click on the canvas to see the
result

The thin outline you see now is
the edge of the artboard...

In the Layers panel, click on the
second (Lock) column for the
Background layer until the lock
icon appears

The layer is locked again

For Your Reference...

To lock and unlock layers and sublayers:
In the Layers panel, click on the Lock

column for the layer or sublayer to
lock/unlock it — the option toggles on and off
with each click

Handy to Know...
¢ You cannot add an object to a locked layer.
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DELETING LAYERS

There are going to be times when you need to
delete layers. Perhaps you have overestimated
and created too many layers, or you decide you
no longer need one of the layers in your

Adobe lllustrator CC - Level 1

document. Whatever the reason lllustrator provides
you with a number of ways to delete layers from
your document.

Try This Yourself:

Continue using the
previous file with this
exercise, or open the file
IL1409 Layers_9.ai...

Same
File

Click on the expand arrow
for Buttons layer to display
all of the sublayers ‘

Click on Layer 5 to select it ‘

Click on Delete in the
bottom of the Layers panel

For Your Reference...

To delete a layer or sublayer.
1. Select the layer in the Layers panel
2. Click on Delete

Handy to Know...

« You can delete layers by selecting the layer
in the Layers panel, clicking on the panel
menu icon and selecting Delete. Alternatively
you can select the layer and press [oel].
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